I bought shares using Zerodha, now I don't know where they are!

Hi all,

I have a trading account with Zerodha and a demat account with IL&FS Securities Services Limited Depository Services. I have been investing in securities for a long time and I am familiar with the clearing & settlement process. I understand that shares will be deposited in my demat account at the end of T+2 days.

I bought shares of 2 companies on 24th April 2018 and 26th April 2018. Lets call these companies ABC and XYZ (I want to keep this information private).

  1. 24th April - 14 shares of ABC and 10 shares of XYZ
  2. 26th April - 10 shares of ABC

Before these trades I had 3926 shares of ABC and 0 shares of XYZ. So after these 2 trades I should have ended up with 3950 shares of ABC.

Trade Confirmation

I received contract notes from Zerodha about these trades. Since I have also registered myself with NSE email alerts, I also received an email from NSE about these trades. So I know that Zerodha placed these orders with NSE.

Discrepancy in Zerodha dashboard

By now these shares should have been reflected in my demat account. However yesterday I noticed a discrepancy in the ‘Holdings’ section of Zerodha’s trading application Kite. I could not see the previous 3926 shares of ABC. I could only see the recently purchased 24 shares of ABC. However I could see shares of XYZ. I immediately wrote to Zerodha Support and informed them about this. Assuming this as some technical error, I did not take it seriously.

However today when I checked the Kite dashboard again I could only see 3926 shares of ABC, not the 24 recently purchased ones.

Check directly in NSDL

I decided to verify the demat balance by using NSDL e-services (https://eservices.nsdl.com/). It allows you to view the securities held in your demat account. To my horror and surprise I could only see the 3926 original shares of ABC. Not the 10 shares of XYZ or 24 recently purchased shares of ABC When I tried to view the recent transactions it said there were no recent transactions! :scream:

I don’t know where the shares have gone. I don’t even know where the error is. Is it with Zerodha, NSE, NSDL, or IL&FS depository services? How should I go about fixing this?

Zerodha opens demat accounts with CDSL now - check over there. What you are seeing in NSDL is correct - you might have bought those shares with a different DP.

2 Likes

Did they reply to your mail? What was their reply?

1 Like

Yes they did reply saying that the ‘Q back office’ is showing things correctly. They also attached a screenshot. After I read the email I logged in to Q back office to verify this. However the 24 shares of ABC were missing from the holdings both on Q back office and Kite. So I wrote them another email today. Still waiting to hear back.

Ah! I think this should be it :sweat_smile: . Recently I started investing in mutual funds via Zerodha’s Coin service. To enable Coin, Zerodha asked me to open a new demat account with Zerodha Securities Private Limited. Zerodha DP is a member of CDSL.

When I check my ‘Profile’ in Q back office, it shows me the DP ID for CDSL. I thought it will only be used for mutual funds, not for shares. I will try to check my demat balance with CDSL and confirm this.

Update: I am on MacOS and CDSL requires me to install Microsoft Silverlight and use Mozilla Firefox to view my demat account holdings. I tried doing this but unable to login into CDSL, Silverlight is not working. If anyone knows a different to check demat balances in CDSL then please let me know.

Update 2: According to this link https://tradingqna.com/t/how-do-i-register-to-cdsl-easi/13301, CDSL seems to work only on Windows with Internet Explorer.

you can check through CDSL App, available on both platform Android & iOS

1 Like

You can check holding in CDSL in MacOs. Follow

  1. Install Silverlight. There is MacOs version, extension of file will be .dmg
  2. Open Safari Browser.
  3. Go to CDSL website.
  4. Select Login to - Myeasi
  5. A new window should open asking for login details, register and go ahead.
  6. If screen is blank, click on Safari menu item.
  7. Select Preferences
  8. Select Websites
  9. On left handside, in plug-ins, click on Silverlight
  10. On right handside, select On for web.cdslindia.com

In spite if you face any problem paste screenshot.

1 Like

Mail your problem to zerodha support@zerodha.com from your registered mail on zerodha.
They usually correct and respond within one working day. Happened to me twice mailing them sorted it out.

1 Like

Thanks :+1: I am now able to open the login page of MyEasi. However when I click on ‘register for easi’ nothing happens. I tried double clicking, right clicking etc. The page does not change.

Great! This worked. Thanks :+1:

Now I can confirm that my shares are in the CDSL demat account.

Yes I have emailed them yesterday. They should hopefully get this fixed by Monday. The Q Backoffice of Zerodha shows up a lot of bugs sometimes! Don’t know when they will fix these things once and for all!

Update

I received a reply from Zerodha’s customer care. They agreed that this is due to 2 demat accounts. To fix this I have to close the older demat account (IL&FS) and transfer my shares to Zerodha’s DP. I think this kind of makes sense in the way that I may be in a very small minority of users who ended up having 2 demat accounts opened via Zerodha. So it may not be a priority for Zerodha to fix this as this only affects a very small number of users. I have made my peace with it and I use CDSL’s app and NSDL’s website to check my holdings.

@fabregas Zerodha have released a new version of Q now rebranded as Console. You can check it out here - https://console.zerodha.com/

I applied to IRCTC OFS & got below response from Zerodha, what should be the next step Can I ask NSE /BSE
I have already checked 1) Funds (OK) 2 timing of application (OK)

what happens if this is glitch from exchange , will i get allotment & who is responsible for this

Below is email I got from Zerodha

Dear Nitin,

We would like to inform you that your OFS order for IRCTC was placed at the Exchange but was not accepted. We have taken up the matter with the Exchange.

Regards,
Team Zerodha

There was issue with the number of ordsrs Zerodha tried to submit to exchange

You can check the discussion here

Thanks for reply

It seems there are lots of Zerodha clients facing the same issue.

Next time will not use Zerodha for IPO /OFS